Requirements

Docker and Docker-Compose

The development of LPWAN Server is largely based on Docker. Docker and Docker-Compose are required to run the Quickstart or run the LoRa Servers for development and testing.

Install Docker

Please refer to the Get Started with Docker guide to install Docker for MacOS or Windows. When installing Docker on Linux, please refer to one of the following guides:

Install Compose

To install Docker Compose on Linux, please refer to the Install Compose on Linux systems guide. You can skip this step for MacOS and Windows.

Git

$ apt install git

Node.js

For development, the system should have Node v8.3.0 or higher and NPM v5.6.0 or higher. We recommend installing Node.js and NPM through a version manager. See the NPM Docs page on Installation